博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
BST(二叉树搜索树)
阅读量:6757 次
发布时间:2019-06-26

本文共 1063 字,大约阅读时间需要 3 分钟。

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries.

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2
31 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2810

Sample Output

1 159 11

Hint

#include <iostream>

using namespace std;

int main()

{
 int T, x;
 scanf("%d", &T);
 while (T--)
 {
  scanf("%d", &x);
  printf("%d %d\n", x-(x&(-x))+1, x+(x&(-x))-1);
 }
 return 0;
}

 

转载于:https://www.cnblogs.com/lengxia/p/4387811.html

你可能感兴趣的文章
QPS,用户平均等待时间,服务器平均请求处理时间
查看>>
uni-app · 支付宝小程序踩坑
查看>>
Wndows server 2008 R2 总是卡住 “Applying computer settings”
查看>>
序列化解决方案,就是采用二进制通信协议(数据报文格式)
查看>>
如何使用Spring优雅地处理REST异常
查看>>
原生JS上传图片(FormData,可预览,一次多图)
查看>>
讲讲Java溢出JVM爆炸的几种方式及自救方法
查看>>
[HAOI2015]T2
查看>>
bzoj 1293: [SCOI2009]生日礼物
查看>>
RadioButton+Fragment 实现导航栏碰到的一些常见问题
查看>>
sudo 出现unable to resolve host 解决方法
查看>>
「小程序JAVA实战」微信开发者工具helloworld(三)
查看>>
文档相关命令-cat命令查看一个文件
查看>>
Java的版本、特性以及开发工具
查看>>
版本控制报告:回答问题
查看>>
巴什博弈------最少取件数 不是1的情况下 hdu---2897
查看>>
因修改/etc/sudoers权限导致sudo和su不能使用的解决方法
查看>>
AT3576 Popping Balls
查看>>
springboot入门_多数据源
查看>>
如果一个游戏上面加一个透明层,js能不能实现 点击透明层的任意点 而正常玩游戏...
查看>>